Trimble GCS900 GCS receiver compatibility

In order to use an MS992 or MS990 Receiver with the newly released MS995 Receiver in a dual configuration on a dozer or grader, users must be running Trimble GCS900 Grade Control System version 13.10 or Cat® AccuGrade™ version 13.10.

Running previous versions of the grade control system in a mixed receiver configuration will result in incorrect system guidance. Upgrading to version 13.10 corrects this issue.

You are eligible to upgrade if you have a current Trimble Protected Firmware plan.
If you would like further information on this upgrades, or Trimble Protected, please contact your local SITECH office or call head office on 07 3851 8370.

Comments for this post are closed.